Problem upgrading Teltonika RUTR950 firmware


We have a problem with 2 of our Teltonika RUT950 devices.

  1. One of them is in version 7.01.2. It does not recognize a new version from the server. When updating from a file i get this error: “The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.” I have tried different versions but same error keeps happening.

  2. The other one is in version 7.02.6. It recognizes a new version from the server. The update process goes through smoothly but after the reboot it is still in version 7.02.6. I have tried different versions via file update but the problem remains.

Do you have any solutions to these problems?

Best regards,


For the first device, I would suggest trying to update the firmware from the file. The firmware for RUT950 can be downloaded from here and uploaded manually.

From the description of the second device, it seems that there might be an issue with flash memory. Have you noticed any other issues with the device? Maybe its losing its configurations occasionally?

I would also suggest to perform the bootloader procedure to completely reflash the firmware. Bootloader instructions are available here (upload firmware to Depending on your device, it may be possible that the bootloader will accept only legacy firmware. In this case, you can upload the legacy firmware via bootloader, and then update to the latest from the WebUI.

In case the issue persists with the second device, I would suggest contacting your designated sales manager or reseller from whom you have purchased the second device to initiate an RMA procedure (assuming the device is still under warranty).

Kind Regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.