Port link state of port LAN changed to DOWN

Hi, we have some RUT955 devices that we have been using for a while. I recently upgraded the firmware on 3 remote routers because of mobile connection issues. This was resolved by doing a firmware upgrade to the latest version (RUT9_R_00.07.04.5).
But one of the three devices now have issues getting a proper connection with the device on LAN3.
This device is powered via the internal relay, so when i try to restart the connection all i can see in the logs is that it brings the link up, only to bring it down right after.

Tue Aug 15 12:18:49 2023 kern.notice Port link state of port LAN3 changed to UP
Tue Aug 15 12:18:49 2023 kern.notice Port speed for port LAN3 changed to 10 baseT
Tue Aug 15 12:19:03 2023 kern.notice Port link state of port LAN3 changed to DOWN

Also 10 baseT is that not a bit low? If im not mistaken, then this should be at least 100 baseT?

I have tried to downgrade to firmware 07.04.03 in hope that it would resolve this issue, but no luck so far.
The device had no problem connecting to the router BEFORE the upgrade.
The old firmware was a legacy firmware. So i upgraded to latest legacy, then latest release of webui, And then i tried a downgrade to 07.04.03.

Im not able to upload the troubleshoot file here becausse my user is new.

Also all three devices are identically configured exept for the sim codes.


The issue happening after the update might be a coincidence, as the logs seem to indicate a physical issue. Would it be possible to downgrade the device to the latest legacy firmware to check if the issue is present even after the downgrade? This would provide me some more insight into whether the issue is related to the hardware, or the software. Thank you!

Best regards,

Hi, thank you for the reply.

if I’m not mistaken, I will loose all configurations when I revert back to legacy firmware right?

If so then it will have to wait until the customer gets the replacement router and send back the one thats not working.
If not, then I will contact the customer so he can get the system back online for testing.

This router is located a very remote place, a plane trip and few hours of driving.

If there is a hardware issue, then I would suspect there might be some issue between the HW on this RUT955 device (maybe batch), and the newer firmware.
The device connected the LAN port have had good and a stable connection for a couple of months. The only issues we had was unstable mobile connection with the legacy firmware.
So it was right after upgrading from legacy to the latest firmware that the LAN connection issues started.

I do have a suspicion that a factory reset possible could be a solution, but I cannot do that until I get the router back.

I’m sure we have multiple routers of the same batch, I just have to check again later which batch this was again.
I recall reading on one if the forum posts a similar issue after firmware upgrade and it being a issue with the batch nr. So there the solution was to return the router back to Teltonika. I will post a link if I find it again.


I’m not aware of this issue, so if you manage to find the post, please let me know.
Since some troubleshooting is required, I’d recommend exchanging the device with a different one, as issues like these are quite hard to diagnose remotely. And correct, going back to the legacy firmware will erase all settings.

Best regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.