Openvpn not routing traffic RUT240


I’m trying to use a RUT240 as an OpenVPN client to a server running on a Raspberry Pi. I can connect to the VPN on my phone and access my local network resources so I am confident that the VPN service is working ok.

I have added the Openvpn client to the RUT and it says it connects but does not show a remote Ip. It also does not route any traffic through the VPN as far as I can tell. Do I need to add a static route or modify firewall settings to pass all traffic from the RUT to the tunnel?

The RUT is running a basic configuration with one LAN and the default firewall rules created by the wizard. It is connected to the internet with a 4g sim for testing but will be behind another router once deployed.

Any help would be greatly appreciated.


Would it be possible for you to clarify how you are checking the connectivity between your RUT client and Raspberry Pi server?

What firmware version is installed on your RUT240?

Also, it would be great if you could share your OpenVPN configurations on both, the server and the client. Before sharing those here, make sure you hide any sensitive information such as public IP addresses, passwords, etc.

Additionally, could you please share IPv4 routes from Status → Routes → Static → IPv4-Routes section?

Kind Regards,

Hi Thanks for getting back to me.

I am checking connectivity to the server on the server asper the screenshot below.

The RUT is on RUT2_R_00.07.05

Config file is as below

dev tap
proto udp
remote server dns name and port
resolv-retry infinite
remote-cert-tls server
tls-version-min 1.2
verify-x509-name name name
cipher AES-256-CBC
auth SHA256
verb 3



2048 bit OpenVPN static key

-----BEGIN OpenVPN Static key

Route tables

Client config


It appears that your OpenVPN is set up in TAP mode. Is this the intended configuration? TAP mode is typically used to connect devices in the same subnets, essentially creating a layer 2 network. In this mode, the server and the client (LAN of RUT) needs to be on the same subnet (for example,

If TAP mode is not required and you need to connect different networks, I recommend configuring OpenVPN in TUN mode (layer 3). This mode is designed for interconnecting distinct networks.

Kind Regards,


Yes this is the intended configuration as I need devices on both sides of the tunnel to be on the same subnet. I have set both subnets to be the same and the lan interface includes the tap0 in the physical settings.


Could you please share some OpenVPN logs from the RUT240?

Also, access the device via CLI/SSH with username ‘root’ and share the output of:

cat /etc/config/network
brctl show

You can hide sensitive information such as public IPs, etc, before sharing it here.

Kind Regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.