OPC Server connection - Invalid URL


I am trying to connect a TRB245 modem to an OPC UA server configured with PC WORX UA Configurator. I am having difficulty getting the modem to recognise the server at all.

The URL created by the PC WORX configurator is created automatically based on the desktop’s name.


When I put this into the URL field of the TRB245 OPC connection settings, it says that it is not a valid URL type with error message “A full url address is accepted”

The example on the website has a URL that is formatted differently, and looks like:
opc.tcp://192.168.x.x:4840. But I am unable to change the format of the URL in PC WORX.

The modem is connected to the same local network as the PC (as well as a PLC hosting the data that I am trying to access via OPC).

Any advice would be appreciated. Happy to provide more information on the setup if it would help/


Could you please check if setting the IP address works in your case?

It seems that OPC UA WebUI configurations do not support hyphens in URLs. I will have consult with our RnD regarding this WebUI limitation.

Meanwhile, if you still need to use the URL with hyphens, you can achieve this by editing the configuration file through the command line interface. Instructions for the command line interface can be found here.

Edit OPC UA configuration file:

vi /etc/config/opcua_master

You will enter a text editor. Press ‘i’ to start editing and use arrow keys to navigate.
Replace the URL option with your desired URL. Press ESC and type ‘:wq!’ to save changes (write and quit). After making the changes, verify if the changes are saved:

cat /etc/config/opcua_master

Then, restart the service:

/etc/init.d/opcua_master restart

Kind Regards,

Thank you for your fast response,

Two points:
I was successfully able to edit the server address to match that made by the server configurator, and am now presented with a new error popup “Tested section has invalid fields”. This is the same response I got when I manually changed the desktop name to remove the hyphen.

I had also managed to change the server URL to the expected format of opc.tcp:// After a short delay, testing gave the error “Test failed”.

I have successfully connected to the server using other clients, so I am fairly sure it is not a server side issue. Is there be a way to make a connection attempt through the CLI so that more in-depth error messages are shown to indicate which part is failing?

Kind regards


It seems that the issue is no related to configuration itself. I suggest taking a look at our wiki articles here and here that provide information about OPC UA and its configurations on Teltonika Networks devices.

Also, I have received confirmation that URL validation will be fixed in v7.5 firmware. For now, you can edit the configuration file as I have mentioned before if needed.

Kind Regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.