Ntpclient not working, Could not resole host

Hi

ntpclient is not working.

with the cli i try:

root@xxx:~# ntpclient -c 1 -h 0.openwrt.pool.ntp.org                     
Could not resolve 0.openwrt.pool.ntp.org                                         
root@xxx:~# ping 0.openwrt.pool.ntp.org                                  
PING 0.openwrt.pool.ntp.org (212.25.15.129): 56 data bytes                       
^C                                                                               
--- 0.openwrt.pool.ntp.org ping statistics ---                                   
5 packets transmitted, 0 packets received, 100% packet loss                      
root@xxx:~# ntpclient -c 1 -h 0.openwrt.pool.ntp.org                     
Could not resolve 0.openwrt.pool.ntp.org                                         
root@xxx:~#                                                              

or

root@xxx:~# ntpclient -c 1 -h 192.168.230.1                              
Could not resolve 192.168.230.1                                                  
root@xxx:~ping 192.168.230.1                                             
PING 192.168.230.1 (192.168.230.1): 56 data bytes                                
64 bytes from 192.168.230.1: seq=0 ttl=64 time=17.866 ms                         
64 bytes from 192.168.230.1: seq=1 ttl=64 time=15.888 ms                         
64 bytes from 192.168.230.1: seq=2 ttl=64 time=17.378 ms                         
^C                                                                               
--- 192.168.230.1 ping statistics ---                                            
3 packets transmitted, 3 packets received, 0% packet loss                        
round-trip min/avg/max = 15.888/17.044/17.866 ms                                 
root@xxx:~#                                                                                                                           

DNS is working, our local timeserver is reachable

So why ntpclient can not synch?

Version RUT955
Firmware version RUT9_R_00.07.05.4
Firmware build date 2023-11-07 18:33:51
Internal modem firmware version SLM750-V_4.57.20_EQ101

Hi,

Welcome to Teltonika Networks Crowd Support!

Can you verify if you enabled NTP Client under System → Administration → Date and Time → NTP

Also, make sure to add your local timeserver hostname in Time Servers.

Let me know if this cleared your doubts.

Regards,

Hello

The NTP settings are correct according to the pictures. Thanks

After a reboot the command worked:
ntpclient -c 1 -h 0.openwrt.pool.ntp.org

This morning I wanted to test it again. Via Web CLI.
It promted ‘Could not resolve 0.openwrt.pool.ntp.org’ again

After logging in again via Web CLI (no reboot) it worked normally. Doesn’t seem to be constant.

Internet connection works. Because everything was tested via VPN tunnel.

Difficult to test the NTP settings and servers. If the time is currently correct. That’s why I thought via command ntpclient… is the best option.

Thanks

This topic was automatically closed after 15 days. New replies are no longer allowed.