"No GPS signal" for RUTX50

Fresh install, newest firmware, GPS antenna outside and GPS enabled, but GPS not working…

Unlikely to be faulty because your problem is common place, and usually it’s a configuration issue. I’m sure someone more knowledgable will help shortly. Don’t expect help today, as admin have probably all gone home for the day now.

Where in the world are you?
Have you enabled the correct satellite systems for your location?
Are you using the supplied GPS antenna or one of your own? Try using the supplied antenna firstly. GPS can take a while to find satellites and calculate location, too, so i’d wait a while.
Not to sure if this is relevant, but is the routers selected location, date and time correct?

Try:

gpsctl -seix

from a ssh or CLI console. What is the output ?

I’m in Europe/Croatia

Using supplied antenna (placed outside).

Config:

Routers selected location, date and time correct? Yes, this:

output:

saran@RUTX50:~$ gpsctl -seix
[main:156] error: Failed to get gps position. ERR: Unable to retrieve valid gpsd response: Not found

And what is the output of

cat /dev/ttyUSB2

?

output:

saran@RUTX50:~$ cat /dev/ttyUSB2
cat: can't open '/dev/ttyUSB2': Permission denied

So the GPS subsystem is not active.
In the “Satellite configuration” submenu, disable NMEA support (all) and try again the cat /dev/ttyUSB2.

Everything was disabled there by default and I didn’t change any config, so it is disabled already.

Not in the screenshot you have posted above.

Which firmware version do you have on the device ?
Try cat /dev/ttyUSB1

Ah, sorry, I thought you meant ones under Service/GPS/NMEA.

Saved

output:

saran@RUTX50:~$ cat /dev/ttyUSB2
cat: can't open '/dev/ttyUSB2': Permission denied

Firmware: RUTX_R_00.07.06.1
(it didn’t also work with version RUTX_R_00.07.04.5 that was originally installed)

Also:

saran@RUTX50:~$ cat /dev/ttyUSB1
cat: can't open '/dev/ttyUSB1': Permission denied

Same output as admin user (part of root group).

Have you updated the modems’ firmware too, no idea if this is relevant though!

I would now probably follow a belt and braces approach and reboot router.

Wait 20 mins and try the commands: cat /dev/ttyUSB1 and cat /dev/ttyUSB2 again.

Then re-enable satellites, save and apply, then reboot. After reboot, wait an hour to see if GPS is working before trying the commands again.

I’d just enable the first two satellite systems myself and leave the Chinese system disabled.

After disabling the non-GPS systems, the GPS successfully locked on my location and it’s visible on Map.

Nevertheless, all commands still return the same:

saran@RUTX50:~$ cat /dev/ttyUSB2
cat: can't open '/dev/ttyUSB2': Permission denied
saran@RUTX50:~$ cat /dev/ttyUSB1
cat: can't open '/dev/ttyUSB1': Permission denied
saran@RUTX50:~$ gpsctl -seix
[main:156] error: Failed to get gps position. ERR: Unable to retrieve valid gpsd response: Not found

Yes, latest one, replied earlier.

Will try what you suggested (rebooting etc.)

Looks like the gps subsystem is not started. Could you check the antenna connection, check that you have satellite visibility, and reboot the router ?

Device firmware and modem firmware are two different things, each updated separately.

Updating the device firmware does not update the modems’ firmware.

Sorry, misread.
The modem’s FW had no update available.

So it works … Why the cat got a “Permission denied” is mysterious.

This topic was automatically closed after 15 days. New replies are no longer allowed.