Load balance with a VPN

Hi all,

I’ve got a RUTX12 with 2x SIMs and 1x 2.4wifi providing internet; I have 1-3 clients connected via 5G wifi to the router. I have tested load balancing and it all works correctly (each interface gives about 20Mb/s, and with load balancing on I get almost the sum of ~75Mb/s which is expected).

I have also tested each interface with a Wireguard VPN connection which works correctly.

The problem I’m running into is that I can’t load balance AND use a VPN. When the VPN is enabled, it only connects through 1 interface.

Is it possible to configure things so that I get the advantages of load balancing AND route that through my VPN? I don’t want to split the traffic according to client; I want all of the traffic split between the interfaces, and then all routed through the VPN.

(I tried to draw an ascii diagram, but it didn’t format well - let me know if a picture is needed and I’ll try my best)

Edit: Also, I should mention that if I run the VPN from my client, it still only connects through one interface even though Wireguard isn’t enabled on the RUTX12


The Wireguard simply binds to one of the WAN interfaces based on the routing (destination IP address, default route, etc). The Wireguard then uses this interface for VPN traffic. There is no option that you can enable on RUTX12 to load-balance a WireGuard instance over multiple WAN interfaces.

You may look into additional scripting/development to see if there is a workaround, however, I am not aware of any simple and working workarounds. Also, this would be out of the scope of our technical assistance.

Kind Regards,

Hi Andzej,

Thanks for your reply. Would it maybe be possible to create a virtual interface, point my WAN interfaces at the virtual interface, and then get them to load balance into that? Then bind Wireguard to the virtual interface?

Edit: Oh, and your reply doesn’t explain why a VPN from the client only goes through one interface? Shouldn’t the RUTX12 be able to load balance that?

This topic was automatically closed after 15 days. New replies are no longer allowed.