L2TP - iPhone connectivity


i have a RUT955 and used l2tp / ipsec to connect my iphone into my home LAN.
this worked pretty well.
i have to admit, that i did not use it for some months and realized now - that it does not really work any more. there are no obvious changes which ave been applied in the meantime. i even tried a different mobile - same behaviour.

the iphone still connects when i “enabled” the VPN - it receives also an IP adress from my home LAN - but it seems that no data is passing through.

can someone explain to me - how i coud configure wireguard connection? i have wireguard on my iphone - and this could also be an option from remote vpn into my home lan - right?

i am running the rut955 on firmware 7.04.4.

thanks !!!

edit: after compare my config with a factory reset rut955 - i realized that the “exlude IPSec from NAT” setting was not enabled on my prod device. enabeling this - made it work again - at least for now.
no idea WHY and HOW this setting has changed “just so by itself” ?


The device should not change any of its settings on its own. There might have been some other configuration changes that impacted the firewall settings.

Regarding WireGuard, we have a configuration example available on our wiki page here. IPSec configuration between the RUT and an Android phone is available here. You can also consider other types of VPNs, such as OpenVPN (example here).

Kind Regards,

hey :slight_smile:
thanks for the reply - i have been out for a couple of days - will go through the docs you are refering to