Issue with Bridge Mode TRB 140 latest firmware


I have an issue that the in the past few fw-versions of the trb140 Bridge Mode is not working and it’s still givning me a NAT adress.

Before it has been a bit buggy but in the latest firmware TRB1/TRB1_R_00.07.05.4, It’s not working at all. Any idea of what fw version would be best. And any roadmap as to when this can be fixed?



Perhaps you have something connected to the TRB140 via the micro USB connector?
Could you share a screenshot of your mob1s1a1 interface configuration? Make sure you have configured your WebUI in advanced mode.
No issues have been reported regarding bridge mode in the past few releases, thus I believe the issue could be in your configuration.
It would also be good to know what device is being connected to the TRB140. Have you tried rebooting the TRB140 with the device is question plugged in?

Best regards,

Hello Daumantas,

We have notice the issue in some of the latests fw releases. And the newest it’s been impossible to come by.

All we do with the modem is set a new password. Go in to the advance mode and change to bridge under mobile as per these instructions:

TRB140 WAN - Teltonika Networks Wiki (

We do not have anything connected to the USB-interface.

The issue is the same regarding if we connect a PC direct to it or our own router.


Thank you for providing the information!
Could you clarify what operating system is running on the PC? I have tried replicating your issue locally, but was not able to - nor on my PC, and on another router.
I will also ask you to replicate the issue, then navigate to Status → Network → LAN, and include a screenshot of the DHCP Leases section. If a public IP is present there, please blur the last two octets, as well as the MAC addresses of the clients.

Best regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.