FMC650 Com port problem

Hello. I use FMC650 Configurator program (1.7.70.B.FM64_R.104) with Windows 11 with usb cable.
I have always COM Port problem. There are two COM Ports COM3 and COM4. When it is connected I see COM4 on the Teltonika configurator. But, in winwos device manager COM 3 and COM4 active.
Teltonika Connects to the PC but in a short time communication is lost.
I have tried many PC’s with Windows 11. Same problem happens.
I have installed the new Firmware FW 03.00.15 Rev3.
But problem is not solved.
For this reason, I can not configure Teltonika.

Please send me your comments for this issue.

Thank you

Hello,
Did you install windows drivers from the first start wiki page ?
Also I had trouble for device detection (same model FMC650 and same os win11), it was because of my endpoint security solution, so I install on a fresh Windows 11, then install .NET 5 (both x86 and x64) drivers, and FMC650 was detected.
Maybe check the usb cable.

1 Like

Hello,

Please follow this link: FMC650 First Start - Wiki Knowledge Base | Teltonika GPS (teltonika-gps.com)

Comport driver: https://teltonika-gps.com/downloads/en/fmb120/TeltonikaCOMDriver.zip
Download the .net file here: windowsdesktop-runtime-5.0.17-win-x64.zip - Google Drive

Regards
Maynard C

This topic was automatically closed after 7 days. New replies are no longer allowed.