FMB965 Send on wakeup

What is the correct behavior of FMB965 sending a packet on power-off mode wakeup? Because there are a lot missing values on the packet that the FMB965 sends when this option is enabled. For example the battery level is always zero.

Hi Lilium,

Good day, Thank you for reaching out to the Teltonika Telematics Community Forum.

Do you mean sleep mode?
Is the battery parameter enabled from the IO?

Best Regards,
Maynard C.

Yes I mean “power-off-sleep” mode that is exclusively on FMB965. The battery level is enabled in the IO because every other packet includes the parameter. There are two scenarios where the packets sent to the server have battery.level=0:

  • When “always make power on record” is enabled and the device is in “power-off-sleep”, the first packet that the device sends when it is woken up has battery.level=0. That is not so problematic for my setup because more packets will follow to cover it.
  • The most problematic scenario is when the device wakes up from “power-off-sleep” without movement. The deice wakes up because it is time to make a new record (as specified in the documentation), and this packet has always battery.level=0. This means that while my moto is not moving I cannot track the battery level. I have set the device to send every 4 hours when is not moving, so if i leave it there for some days I have no way to get alerts for the battery level of the FMB965.

P.S. Talking about the battery of the FMB965, you can’t just put there a 10x bigger battery and have the same charging IC/Settings. Charging a 1200mah battery with 0.160A ,as in FMB920, means that it will never charge on a trip.

This is a sample packet from flespi that FMB965 sends when it is in power-off-sleep mode and it is time to send to the server:

“battery.current”: 0,
“battery.level”: 0,
“battery.voltage”: 3.904,
“”: 1170620,
“”: 5278467,
“”: “CB500X Tracker”,
“”: 1217,
“din”: 0,
“din.1”: false,
“dout”: 0,
“dout.1”: false,
“engine.ignition.status”: false,
“event.priority.enum”: 1,
“external.powersource.voltage”: 0,
“gnss.state.enum”: 2,
“gnss.status”: true,
“gsm.cellid”: 0,
“gsm.lac”: 0,
“ibutton.connected.status”: false,
“ident”: “removed”,
“movement.status”: false,
“peer”: “”,
“position.altitude”: 0,
“position.direction”: 0,
“position.hdop”: 0,
“position.pdop”: 0,
“position.satellites”: 0,
“position.speed”: 0,
“position.valid”: false,
“”: 14,
“server.timestamp”: 1694567967.811865,
“timestamp”: 1694567953

You can see that battery level is not calculated. The device is not connected permanently to the battery, it takes power only when ignition is on. That’s why “external.powersource.voltage”: 0.