FMB130 OBD2 Bluetooth reconnect

Hello,

I sucessfully got OBD2 parameters transmitted to my server,
however this only work once. The FMB130 is powered 24h from car battery.
After a break, the FMB130 bluetooth does not connect again to the OBD2 Bluetooth dongle.
I have to reboot the FMB130 to get it working again.

The documentation says:

Connecting to Bluetooth OBD II dongle


After this configuration OBDII dongle can be connected to FMB device. Turn on the ignition, then turn on its Bluetooth connection. For pairing follow dongle instructions. OBDII device notification about paired Bluetooth connection depends on the specific model. If you later restart FMB device it will automatically reconnect to this dongle

Is there any other way to get Bluetooth connected agai without reboot?

Thanks
Carsten

Hello,

Good day, to understand the situation, Once you turn off the vehicle the OBD dongle also turns off right? And then the FMB130 didn’t reconnect after that?

Can you create a Helpdesk ticket for this or contact your sales manager, we need to analyze your situation.

If you don’t have any contact with our Sales managers, please contact them on our official website https://teltonika-gps.com/ and click on the “Contact Us” button. When you click, please fill out the form and submit it. Note: as a topic, please choose “Vehicle telematics”. Or you can send an e-mail with a description of your situation to info@teltonika.lt When contacting Us, please provide:

  • IMEI
  • Logs
  • Configuration file
  • Intenational GSM number
  • Firmware version

Please follow these recommendations: Recommendations for filling a query description - Wiki Knowledge Base | Teltonika GPS

Best Regards

Hi Maynard,
yes, the OBD dongle turns off when vehicle is turned off.
I then need to reboot the FMB130 after vehicle ignition is turned on again.

I also used Bluetooth 4.0 BLE to check if the dongle would reconnect and it does.
But I only get the BLE name and ID here.

I will create a ticket now.

Thanks
Carsten

still got no replay from helpdesk…

My current workaround is to send Codec12 GPRS command “cpureset” at 2am every day.
I will extend this to also send reset command if vehicle movement detected and no OBD data received.

Regards
Carsten