Firmware RUT2_R_00.07.06.6 not present after succesfull update

I have RUT240 which shows

Current firmware information

  • Firmware version
    RUT2_R_00.07.06.5
  • Firmware build date
    2024-02-15 08:24:06
  • Internal modem firmware version
    EC25ECGAR06A04M1G_01.004.01.004
  • Kernel version
    5.4.259

Update shows new update is available.

Firmware available on server

  • Firmware version
    RUT2_R_00.07.06.6

I tried online update twice, no error shown but after message Reboot in progress and wifi reconnection, device still shows 7.06.5 installed.
Tried update from PC with firmware downloaded from RUT240 Firmware Downloads - Teltonika Networks Wiki
Even after uploading file from PC, result is the same. It won’t install.

Everytime confirmation with green confirmation messages (and hashcodes) was shown, that new FW is ok to install.

Event log shows only

ID Date Event Type Event
18 2024-03-07 13:18:08 Reboot Request after FW upgrade

no error can be found.

Where can I find report why FW is not installed?

After multiple restart and (possibly) disabling OpenVPN client update finished. After 5 attempts.

This topic was automatically closed 40 hours after the last reply. New replies are no longer allowed.