Firewall zone forwarding


following up the discussion in the former forum RUT240 Wifi repeater UI change with new FW - Crowd Support Forum | Teltonika Networks

I want to use a RUT240 as a wifi repeater to boost wifis.

I followed the instruction [RUTOS relay / Wi-Fi extender / repeater / bridge configuration - Teltonika Networks Wiki]

Andzej told me the following: “To ensure that two-way communication, navigate to Network → Firewall → General settings and edit the WAN zone (WAN => LAN ). Add LAN zone in Inter-zone forwarding to Allow forward to destination zones section.”

However when I save the configuration I receive an error message: “Failed to edit configuration”. See pictures with the following link: kDrive. Could you please help me to configure the firewall?

Many thanks in advance.


Apologies for a late reply.

I am unable to replicate this issue on my device. The firewall change is saved successfully.

Could you try restoring the device to factory settings and reconfiguring it again?

If this does not work, you can try another two things:

In the Network → Firewall settings, for the WAN => LAN zone, change input/output/forward to accept. This should not be an issue if the device is configured in WiFi bridge mode.

Another option would be to access the command line of your device following the instructions given here, using ‘root’ as the username and your WebUI password.

Execute the following command to edit firewall settings:

vi /etc/config/firewall

You will enter a text editor. Press ‘i’ to start editing and use arrow keys to navigate. Add the following rule to the end of the file (you can change the rule number ‘50’ according to the numbering of your rules):

config forwarding '50'

    option dest 'lan'

    option src 'wan'

Press ‘ESC’, type ‘:wq’ and press Enter. This should save the changes. Then, verify that those are saved via:

cat /etc/config/firewall

When changes are made, restart firewall:

/etc/init.d/firewall restart

Kind Regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.