Duplicated arp entries

Hi team

Have a strange issue with RuTXR1.

Have approx 300 clients on static IP, across two port based vlans. A small number of reserved dhcp addresses for admin/servers.

My interface list includes
Lan (router is .254)
A vlan1 which is
Vlan2 which is

I always thought it was weird to have both Alan and vlan1 but it never caused any problems.

Recently I simply change the rut from using sim2 to sim1. This caused some very strange effects which included dropping all the clients and making the vlan entries all disappear. I also lost my routing via zerotier.
A remotely commanded reboot restored most access except for a handful of clients and still no zerotier access or any ping access to the handful of servers on reserved dhcp addresses.
If I run arp -a I get the full client list but doubled up: 1 entry has the correct MAC address the other has 00:00 etc (see screenshot).
I also noticed the number of connections go to 6000!!

It seems unusual to me but I can’t quite place the issue. Any ideas?

I think the Lan and Vlan1 interface double up
are probably the cause somehow, but I haven’t changed either of these settings and it had previously worked fine.
This is very remote so I’m conservative about changing anything that will lock me out of remote access.
Zerotier works to route me to the router web ui just fine, and to the vast majority of static clients but not the reserved address servers previously mentioned.

Resolved after I noticed that the Interface order had been changed.
Interface Vlan1 was above Lan, so it superseded the Lan interface which defined the DHCP range the missing servers were addressed in.

Still interested to know:
Does it make sense to have both Lan and Vlan1 with the same subnet\24?


Having duplicate IP can cause routing issues and can be a headache to resolve. No two interfaces should be in the same IP range. Remember, that the LAN zone is also a VLAN with ID 0, so it is no different to VLAN1 or VLAN2.
As for the ARP table, since the entries are incomplete (Flags are 0x0: linux - Definition of Arp result flags? - Super User), I’d simply ignore them.

Best regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.