Device lost after changing static IP - RUT241


Last few days I got a problem, on more than 1 router, where when I change an already set Static Lease Adress for a device, the device becomes lost and won’t get the new address when the new lease starts. It is not pinger with the new nor with the old address. I tried reseting everything., giving the old static address back, deleting it completely letting it give whichever one he wants. The device just seems to be lost.

It already happened on a few different Routers, after the same static lease change & when the old lease expired.

old address:
new address:

Neither of them were in use, there is just one DHCP on the Network. Lease Time is 48h.

One fix was that this particular device was disconnected manually from the Network & Power. Then she gets the normal new address. Since most of the routers are remote, I can’t access them to disconnect the power on every one of them.

Thank you.


It seems that the end-device asks for the address, but the router offers the address. The device does not take it, and after some time asks for the old address again.

Does this happen only to one device?

What device is that? If its a Windows machine, you can renew dhcp manually to see if it works via ipconfig /release followed by ipconfig /renew.

Also, could you lowering the lease time? Though this is unlikely to helps since the end device itself does not take the new IP address.

Kind Regards,

Hi, Thank for reaching out.

I also tried force giving it the old address, but it still does not show up. And the logs also show that that it asks for that address and gets it, but next steps don’t occur. It happened on a few devices, after the static ip is changed and the lease of the old address expired.

I also tested with 2 & 5 min lease times. It is the same.

The Device itself is some sort of a Rasp Pi. Most likely it is that it is a problem on the devices itself, since the ones that show problems got some new update. But I am waiting on official support to answer so that I know for certain.


One other device, which got the Adress it was looking for, has the same Problem (see screenshot)

This topic was automatically closed after 15 days. New replies are no longer allowed.