DDNS configuration for Namecheap (or other custom)

There was this one question in the old forums about Namecheap DDNS on RUT device. I could not get my Namecheap configuration working, so I thought that it is good idea to share my workaround. I don’t know how to config subdomain properly with provided Namecheap config, so if someone could tell me it would be much appreciated. I will roll with this workaround until that. I have TCR100 but works for all routers I think.

Just use – Custom – option with correct URL. Example below, keep the [IP] part as is and the router will automatically add the IP address you specify in the options. Replace SUBDOMAIN with @ if you want to change the base domain.

https://dynamicdns.park-your-domain.com/update?host=SUBDOMAIN&domain=EXAMPLE.COM&password=THE_LONG_DDNS_PASSWORD&ip=[IP]

Hello,

Thank you for sharing, and yes, you are correct. With DDNS, you need to use ‘@’ symbol for subdomains. This information will be included in our wiki in the future.

Kind Regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.