Data limit RUTX50


Please someone explain me why my router after I put data limit on both sim in the sim 1 happens something strange like if I used all the traffic in less then 1 hour?

When I set the data limit was 0 to 649gb now after some traffic is 649 to 649 and normally like this the router switch the Sim even if I don’t want because there is lot of traffic to be used.



There were some issues with Mobile Data calculations on older firmware versions. Could you please clarify what firmware version do you have installed? If it is not the latest, please update the device to the latest firmware version with ‘keep settings’ option disabled and see if the issue persists. Firmware for RUTX50 can be downloaded from here and uploaded in System → Firmware.

Kind Regards,

Perfect I think i have the previous version v7.04.3 it is important to leave the keep setting? Because I have some static lease and many more option saved and is important to keep this setting for me!

I have other question about ethernet speed, by default there is some option that don’t allow the gigabit lan to get full speed? Because even if I use Cat 6 cable the speed of my network is limited to 30/50 mbit in download even if I have more then 150 mbit available, if I try with 5.8g Wi-Fi I get more speed then the pan and is so strange!


Since you are having issues, I would suggets updating with ‘keep settings’ disabled as there is a chance that there will be issues if you migrate your configurations.

As for the LAN, there should be no need for additional settings. Do you have other devices using the RUTX50 for internet connection? Or is that the only device connected to RUTX50? Also, please try enabling ‘software flow offloading’ in Network → Firewall settings.

Kind Regards,

Ok i am trying with leave keep setting.

When you do this the modem loose al setting? Like webui password, Wi-Fi name ext ext?


Yes, all the settings will revert to their initial configurations. The password will either be the previous default password (admin01) or, for newer devices, a unique, randomly generated password displayed on the device’s label.

Kind Regards,

Ok thanks :pray:

Firmware updated i’ll keep you update about traffic limit setting. Just to know, before update i have 5G NSA connection always now is just 4G+ (LTE A) why?

I see this on changelog: * Fixed device showing 5G connection when 5G connection is not established or configured

So i have a question… In my location my iPhone 12 Pro works with 5G connection, of course is NSA network it is normal that the modem doens’t do the same? When the RUTX50 works in NSA mode? How many band need? Because mine is always connected to B1 and B3



After the upgrade the data limit show the same issue like before, data amount after a bit from 0/649gb go to 649/649gb

Same situation after a bit of traffic


The internal modem itself decides to which bands to connect and is not defined by us. Generally, it connects to the bands with the strongest signal to provide a stable connection, which does not necessary provide best speeds. Do you have any whitelisted bands or is everything on auto as per default settings? If possible, could you please share the output of the following commands from CLI?:

gsmctl -A 'AT+QCAINFO'

Regarding mobile data usage.

Please share your mobile data usage, as well as data limit configurations.

Also, could you please clarify if you updated the firmware with ‘keep settings’? If so, would it be possible for you to reset the device to factory defaults?

Kind Regards,

I think is correct for now that modem doesn’t show 5G SNA because I search with a LTE map in Italy where there are the tower with 5G NSA or SA and there is no 5G frequency active for now.

A guy told me that when a smartphone see 5G also where there is no network is called Upper Layer Indicator in fact is 4G connection.

Anyway this is my situation:


+QCAINFO: “PCC”,1350,100,“LTE BAND 3”,1,151,-66,-7,-39,18
+QCAINFO: “SCC”,275,50,“LTE BAND 1”,2,277,-86,-9,-59,19,1,50,18275

About the data limit yes I have updated without keep setting but after more or less 10gb of traffic the counter show full data used


Indeed, it seems that is what available in your area. So everything seems correct from this output.

Regarding the data limit, I did some additional testing on my end with 7.04.5 firmware. I noticed that the overview page sometimes displays inaccurate mobile data limits, especially after changes or service restarts. However, a hard refresh (using Ctrl + F5 in Chrome) shows the correct data limits. Can you please try doing a hard refresh on the overview page multiple times and check if the displayed limit is accurate?


Kind Regards,

Tried to do what you told me but nothing change. Anyway i have upgraded the modem to the lastest firmware released this morning and now show the correct data for now, also the second sim is good now, before without using it show full data, now seems that it is correct and show N/A


So everything is working properly now since you updated the firmware?

Let me know if the issue occurs again.

Kind Regards,

Yes everything work good now!

I have just an issue with local network where I can’t enter inside a local IP of Raspberry PI by port 1880 with browser, tried many options but I didn’t understand why I can’t do no more this things

This topic was automatically closed after 15 days. New replies are no longer allowed.