Data connection disconnected (Rutx50)

I am so sad, (I know this is my second topic, forget about the old one).

I invested 1000+ euros in a RutX50 with a “Poynting” antenna and now I’m using an old 4G modem that works like a CHARM!!!

Same SIM card, same camper same network…

What is wrong with the RutX50 for it not to work!?

I tried to add a APN (the other 50bucks 4G modem never needed one), I tried updating latest firmware, I tried a factory reset after this, I even asked a camper on the campsite the same question with a Rutx50… he told me straightforwardly HE GAVE UP?! So two dudes with to much money spending on state of the art hardware are now using an old 4G modem and iPhone hotspot :joy:.

Teltonika what is wrong with the RutX50 to not get it to work in a to the sim foreign country (for both it worked fine at home).

If there is anyone reading this from Teltonika, could you please reach out to me, I’m here on the campsite with this other dude with the same issue for another 4 days.

if not I now two very cheap Teltonika RutX50s for sale :smiling_face_with_tear:


There are a lot of people on this forum who are owners of RUTX50 and a lot can say that “we feel your pain”! One does hope Teltonika is reading this, because it’s another nail into the coffin of RUTX50, IMO. And if Teltonika comes up with another “maybe best thing for you is to contact your reseller and RMA it” - do let the forum know, at the very least you’ll get some karmic credit for steering others from making same mistake as we have done.


After finding another (Italian) RutX50 user on the same campsite; bij walking around with WiFi finder on, he presented us with a solution used before.

Factory reset the modem and use a LOCAL sim, we used the neighbours IPhone France telecom SIM. We installed the RutX50 with this SIM card and it worked!!!

Then swap for your own (foreign) SIM card and all angels start to sing!

Incredible why this would work, but for us BOTH this worked!

I have the same issue, (Data connection Disconnected).
But my issue isn’t solved yet.
After some startup problems with my RUT 955, it works fine for almost 2 years.
On my camper trip back from Kroatië to Slovenia, the 4G data just stopped.
It never gets on. Also not in Austria and Germany.
Reboot or my other SIM from my iPhone gave the same results!
router SIM in my phone works also fine.

Back in the Netherlands, still the same with both SIM’s!
also SIM swapped from slot 1 to slot 2.
After firmware update, also the same.
What is going wrong?

Please help to solve this

1 Like

a lot. It’s a shitty router. I have one believe me.

Thanks for your reply, but this hasn’t help me to solve my problem.

I partly agree with you. It cost me a lot of time but my problem is solved for now.

  • I made a factory reset.
  • I load the latest firmware, what didn’t work, so first loaded old firmware (6.xx)
  • setting up data connection didn’t work.
  • Loading latest software firmware.
  • restore old settings was not possible (memory failure)
  • setting up all settings from scratch.

Finally that works.

But I still busy to set al other setting such as GPS, what’s going not so smoothly :frowning:

1 Like

This topic was automatically closed after 15 days. New replies are no longer allowed.