Custom DNS not working on 7.6.3

Hi,

We have a RUT955 (192.168.1.1) running 07.06.3 and are experiencing DNS issues.

From the RUT955 we can’t resolve iot.beans.be. On the RUT955, when we do a nslookup iot.beans.be 192.167.17.18, it resolves successfully (see below).

root@RUT955:~# nslookup iot.beans.be 192.168.17.18
Server: 192.168.17.18
Address: 192.168.17.18#53

Name: iot.beans.be
Address 1: 172.16.200.20
*** Can’t find iot.beans.be: No answer

However, a ping towards iot.beans.be does not (see below).

root@RUT955:~# ping iot.beans.be
ping: bad address ‘iot.beans.be’

We have 1 SIM inserted and 4G connectivity is working. We can resolve general hostnames like google.com, coolblue.be, …, but we have configured a custom DNS configured on mob1s1a1 and this is also visible in an ifconfig.

When we manually update /etc/resolv.conf and update the nameserver from 127.0.0.1 to 192.168.17.18, the RUT955 starts to resolve iot.beans.be.
After a reboot, this change is lost.

A LAN device connected to the RUT955 is also not able to resolve iot.beans.be.

Is there anything else we can check or update?

Tom

Ok, found the issue… Under Network>DNS - the option Rebind Protection needs to be set to OFF instead of ON (default).

This topic was automatically closed 40 hours after the last reply. New replies are no longer allowed.