Accessing devices on remote network with TRB140 and wireguard

I set up a wireguard server on my local network ( and a wireguard client on a TRB140 (connected via 4g) on a remote network(
I need to connect to the devices on the remote network from my local network but as of now i can only do the opposite.
On both sides allowed ips are set to and the teltonika firewall zones are set as follows:

  • lan>wan/wireguard accept/accept/accept, masq off mss clamp off;
  • wireguard>lan accept/accept/accept, masq on mss clamp off;
  • wan>REJECT reject/accept/reject, masq on mss clamp on;

i can’t even ping the TRB140 at from the local network
What am i doing wrong?


Please, follow the configuration example here. Make sure you add LAN networks to the ‘allowed IPs’ and enable ‘route allowed IPs’. The allowed IP should look similar to this (you can replace 10.0.0.x with whatever you use for the tunnel):

Server - + (allow trb)
TRB - + (allow server)

I would also suggest seting a lower MTU of 1300 for example, and adding persistent keep alives of say, 25.

If you are still having issues, try pinging the public IP address of your server from System → Troubleshoot page to see if you can reach the server. Then, share your WireGuard configurations (hide sensitive information, like part of public keys and public IP addresses). Additionally, you can check wireguard status when connected to the device via CLI/SSH with username ‘root’ and executing the ‘wg’ command.

Kind Regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.