Access to GPS data through public static IP RUT955


I need to get GPS data through SIM card WAN port to external application. My SIM card has public & static IP. I can connect to WebUI by browser or ping device through SIM card WAN without any problems.

I’ve tried two solutions to get GPS data - Modbus TCP Server and SNMP. Everything works great when I’am connected to LAN port of Router, but if i need to reach Modbus TCP Server or SNMP through my SIM Card IP - devices refuses connection in both solutions. Of course in both configurations, i’ve enabled Remote Access.

Is there something i’ve missed in configuration ?


I’ll ask you to share a few screenshots that will hopefully help us determine the issue:

  • Screenshot of the Network → WAN → mob1s1a1 interface, with the second two octets of the IP address blurred like so:

  • Screenshot of the Network → Firewall → Traffic rules (in particular the last half of the page).

From the current information it seems like everything is configured correctly, so the main suspects currently are:

  • Missing firewall rules;

  • Carrier blocking such packets;

Best regards,

Hello, Thank you for fast answer. Screens below:

mob1s1a1 interface:

I can put only one image to one post


Additionally, below is SNMP tracking on Wireshark :

It seems like the issue is with the firewall rule. Please edit it to be 161 as the destination port, not the source port.
I’ve tested this with 07.05.4, but the rule was created successfully, not sure why it was created this way in your case.
Let me know if this helps!

I think I’ve added it manually (just to try everything).

Below the screen with updated rule:

And the problem is the same. Sending request, but there is no response.

Another issue, the source zone should be WAN (which is correct), but the destination zone should be Device (input). The rule should look like so:

Now it works ! Thank you for your reply. Destination address must be Any, not with specified IP - that was a problem.

Thank you again and regards.

1 Like

This topic was automatically closed after 15 days. New replies are no longer allowed.