5G not working on TRB500

Hey!
I have been having some issues like for 5 months.
The device just CAN’T seems to connect to 5G.
I have asked the ISP (Elisa Oyj) about this and they know nothing about this.
I also made a post to the old forums about this and then it was said that “It comes in a update”.

I am in Finland btw.

Sincerely

  • jaskazzz

I have the same issue with TRB500 on Elisa network in Finland. 4G LTE/3G works fine but 5G does not recognize any network.

Is this a widespread problem with this device? Or should I do a warranty return of the device?

Hello,

The issue refrenced in the old forum post has been implemented in v7.4.3 release, thus if you’re running this firmware ir newer, there’s most likely a different cause.
Additionally, I’ll ask you to run the commands provided here: TRB500 - modem disconnecting - #5 by Daumantas to check the current connection status. Before performing these steps, please make sure that your location has 5G coverge by inserting the SIM into a mobile phone.
Since Elisa is using 5G NSA deployment, it is not possible to force the device to connect to 5G. It first has to connect to a 4G cell, and only then can it connect to one of the 5G bands. From the information I found online, only Telia currently has a 5G SA (standalone) deployment, where the device can connect in 5G-only mode.

Best regards,

Thank you.
I will also ask you to remove the SIM card and run the following command:

ubus -t 500 call gsm.modem0 exec '{"command":"at+qscan=2","timeout":500}'

This will perform a scan for nearby 5G NR cells. It can take a few minutes to complete, during which the device will not have internet connection. Please paste the output in the next comment.

Best regards,

I will not be able to perform this action before this topic automatically closes. Can I send it some other way?

Hello,

I’ve changed the date the topic closes. Post the results when possible.

Sorry if this took so long!
My output is here:

{                                                                  
        "request": "at+qscan=2\r",                                      
        "response": "\r\n+QSCAN: \"NR5G\",244,12,650688,310,-101,-11,27,
",244,91,156510,745,-91,-11,40,0\r\n+QSCAN: \"NR5G\",244,91,156510,746,-
N: \"NR5G\",244,05,641280,103,-70,-11,54,1\r\n+QSCAN: \"NR5G\",244,05,64
r\n\r\nOK\r\n"
}                                                        

Thank you for the information.
It seems like there is one 5G cell around you from Elisa:

\"NR5G\",244,05,641280,103,-70,-11,54,1

So if the device is not connecting to this cell, there is most likely a limitation imposed by the carrier. Could you check if the same SIM provides 5G connectivity in your mobile phone?
Additionally, some carriers whitelist devices that can connect to 5G, could it be the case that Elisa only allows certain devices to connect? Perhaps you have a different SIM from another carrier to test 5G with? Both DNA and Telia seems to have cells nearby.

Best regards,

I have tried to use the SIM on an phone, it works.

I have also tried DNA but not yet Telia

DNA did not work either?

Yea, it did not work

Could you also post the output of these commands on both DNA and Elisa (if both SIMs are available): 5G not working on TRB500 - #4 by Daumantas

This topic was automatically closed after 25 days. New replies are no longer allowed.