Ask a question

2497 questions

3021 answers


2240 members

Ask a question
0 votes
asked in Networks by
Hi, I use Japanese version of RUT955. Several weeks ago, there were no problem and worked fine.
But recently, it became to fail recognizing the SIM card. I have 2 RUT955 with EC25-J and 3 with EC25-E.
This issue is observed only on with EC25-J. (The same sim card works with EC25-E)
The LED on the right bottom is blinking in red/green and others are off.

I'm not sure but changing point was firmware update.

What can I do to recover my RUT955?

Followings are command response from EC25-J:
root@Teltonika-RUT955:~# gsmctl -w

root@Teltonika-RUT955:~# gsmctl -m

root@Teltonika-RUT955:~# gsmctl -y

root@Teltonika-RUT955:~# gsmctl -i
8.......................061  [Masked IMEI is valid]

root@Teltonika-RUT955:~# gsmctl -J
898..................................F  [Masked, SIM Card ID is valid]     

root@Teltonika-RUT955:~# gsmctl -z

root@Teltonika-RUT955:~# gsmctl -j   

root@Teltonika-RUT955:~# gsmctl -g

1 Answer

0 votes
answered by


Could you generate troubleshoot by going to System > Administration > Troubleshoot after this issue occurs, then downgrade firmware version to one where SIM card worked and generate another troubleshoot file.

After doing that, please send them to me via Private Message.

commented by
Hi Peasant,

Thank you for your comment. Here is the troubleshooting file.

I'd like to try older version of firmware but where can I get them?
commented by

Hello, I removed troubleshoot file from your comment, I advise to send it via private message next time.

I downloaded troubleshoot file before removing it, so I'll take a look at it and get back to you with more information.

Regarding older firmware versions, you can find them here:

commented by

Hello, thank you for removing file, sorry about that.

I downgraded to RUT9XX_R_00.06.00.2 but no situation change.

I'm waiting for your feedback.
commented ago by

Could you try executing these commands while connected to the router via SSH?

  • gsmctl -A AT+CPIN?
  • gsmctl -A AT+CPIN=<pin_code>
  • gsmctl -A AT+CPIN?
Instead of <pin_code> enter your SIM cards PIN code
And after could you generate a troubleshoot file again and send it to me via Private message?
commented ago by
Hi, I sent troubeshoot file via private message.