Ask a question

2286 questions

2781 answers

3510 comments

1931 members

Ask a question
0 votes
59 views
asked in Networking by
can not work with mqtt  (rut950 v.6.04.1)

publisher enabled without user/pass ,  IP same as router IP (192.168.3.1)

trying to subscribe with PC software (mqtt_spy) , but no answer

tested with other device (SonOff energy meter/relay with tasmota firmware) connected to router Broker, and works fine

* could be interesting if some status line on publisher screen , like ... if enabled...<connected to broker OK>

1 Answer

0 votes
answered by

Hello,

Are both publisher and broker are available?

I tested this functionality on RUT950 with RUT9XX_R_00.06.04.1 and it seems to work fine. Could you double check your configuration? Here is mine:

commented ago by
yes Peasant, my basic software setup for testing was like yours, and enabled both

uummmm...... now it works ... but:

looks like I need to "reboot router" when make any change on PUBLISHER / BROKER  enable/disable.

can connect/disconnect to BROKER, but sometimes PUBLISHER do not answer

and I need to "power off...on"  not only "reboot"

- I tried a factory reset and check with default router settings, and just only enable/disable broker and publisher

- and again restore my last configuration but the same results

maybe is my fault , something that I am doing wrong but can not discover

something like a PUBLISHER "blocked" situation and then no response ???

* my solution: with broker and publisher enabled .....power off...on  (do not change broker/publisher when router running)

then looks like it work fine , can get ID, temperature, signal, ...