Ask a question

3061 questions

3722 answers

4760 comments

3199 members

Ask a question
0 votes
118 views
in Networks by

Because I didn't get an answer for my comment on previous questions on https://community.teltonika.lt/10071/rutx11-firmware-rutx_r_00-02-00-wirelles-problems?show=10874#c10874

I repeat it:

Thanks for 2.00.2. It works better. But I have still issue with this version.

Steps to reproduce:
1. No wwan interfaces for 5GHz
2. Add interface as Client Mode:

3. RUTX11 connected to SSID:


BSSID is still incorrect. For me (for ClientMode) should be BSSID of connected AccessPoint

4. Add new virtual interface as AP
5. 5GHz wireless stop working:

6. Link to troubleshoot file: https://drive.google.com/open?id=1xjsOpFdlhYge1SHgHU3u32T5ceaFpykZ


What about my previous questions?
1. Will wpa_supplicant option bgscan will/should work? If yes where can I write this option? When I put it to /etc/config/wirelles the option not moving to wpa_supplicant.config
2. After a switch to mac80211 WiFi driver, the wpa_cli command disappeared. Will you plan to restore this command? I was planning test: "wpa_cli [options] roam BSSID"

1 Answer

0 votes
by
Hello,

I managed to replicate the BSSID issue, but could you please tell me more about the steps you took to make 5Ghz wireless to stop working?
by

Steps:

1. No network configured for 5GHz

2. Scan and join to know SSID

3. Change Channel to auto, ESSID to know SSID name, BSSID to null

4. For now, everything is ok. RUTX11 connected to SSID

5. Add new virtual AP

6. After that 5GHz wireless stops working

by
May I ask why you chose auto mode again although when you scanned network it chose the channel automatically? Regarding the BSSID we already informed our technicians.
by
Because we want to install RUTX11 in AutomatedGuidedVehicle. And this AGV will drive around the production hall which is associated with roaming between AP's. So I don't what choose specific channel because those AP's will have different channels at this production hall.

Second: when I did it the same steps on 2.4GHz it works.
by
Thank you for all the details. I will forward this information to our technicians.
by

Thank you

Please ask them also for:

1. Will wpa_supplicant option bgscan will/should work? If yes where can I write this option? When I put it to /etc/config/wireless the option not moving to wpa_supplicant.config
2. After a switch to mac80211 WiFi driver, the wpa_cli command disappeared. Will you plan to restore this command? I was planning test: "wpa_cli [options] roam BSSID"

by
Hello,

BSSID will be fixed and wpa_cli will be added in upcoming update. If you want to use AP/Client at the same time, use 20MHz channel width and it will work. Regarding the roaming between AP, we suggest you to not create on the same AP interface, just STA (client). Or to create client mode interface without auto channel.
by

If you want to use AP/Client at the same time, use 20MHz channel width and it will work

I checked it before. It also not working.

Regarding the roaming between AP, we suggest you to not create on the same AP interface, just STA (client). Or to create client mode interface without auto channel.

It is a proposition for now until you will fix this issue?

by

Try to restore your router to it's factory settings and try again. If it still does not work, try to reboot the router and wait a few minutes it should start.

It is a proposition for now until you will fix this issue?

It is a suggestion to configure it this way.

by

Try to restore your router to it's factory settings and try again. If it still does not work, try to reboot the router and wait a few minutes it should start.

I did it many times without success.

In log file always have logs similar to this:

- cat: can't open '/var/run/wifi-phy1.pid': No such file or directory

- cat: can't open '/var/run/wpa_supplicant-wlan1.pid': No such file or directory

And why in firmware version 1.0.6 it works well?